[gelöst] Woher bekommt man ....

Fragen und Informationen zur Installation von Gambas
Antworten
roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

[gelöst] Woher bekommt man ....

Beitrag von roemi » So 18. Jun 2006, 10:09

http://www.gambas-club.de/viewtopic.php?t=108

Hier hatte ich leicht und locker beschrieben wie man installiert und fehlende Dateien ergänzt.

Aber bei
- gb.compress.bzlib2
- gb.corba
- gb.db.firebird
- gb.db.odbc
- gb.gtk
- gb.net.curl
- gb.pdf
- gb.sdl
will mir das nicht gelingen.

Ich habe nun soviel Zeugs installiert ohne das sich was geändert hat,
Hat jemand eine Idee? was muss man wählen?
Zuletzt geändert von roemi am Mo 19. Jun 2006, 08:47, insgesamt 1-mal geändert.
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

Beitrag von roemi » So 18. Jun 2006, 13:29

Als Beispiel: Unter SuSE 10.0 konnte ich ein Paket Namens gtk-devel finden.
Unter PCLinuxOS finde ich es nich.
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

Beitrag von roemi » Mo 19. Jun 2006, 08:44

:oops: :oops: :oops:

To compile Gambas, you must install the following libraries on your system :

Components = Libraries
gb.compress.bzlib2 = libbz2.so
gb.compress.zlib = libz.so
gb.corba = libACE.so libomniORB4.so libomniDynamic4.so
gb.crypt = libcrypt.so
gb.db.firebird = libibpp.so libfbclient.so
gb.db.mysql = libmysqlclient.so libz.so
gb.db.odbc = libodbc.so
gb.db.postgresql = libpq.so
gb.db.sqlite2 = libsqlite.so
gb.db.sqlite = libsqlite3.so
gb.gtk = All GTK+ libraries
gb.ldap = libldap.so
gb.net -
gb.net.curl = libcurl.so
gb.opengl = libGL.so libGLU.so
gb.pcre = libpcre.so
gb.qt = libqt-mt.so.3
gb.qt.kde = All KDE libraries
gb.sdl = libSDL.so
gb.sdl.sound = libSDL.so libSDL_mixer.so
gb.sdl.image = libSDL.so libSDL_image.so libSDL_gfx.so libSDL_ttf.so
gb.sdl.opengl = libSDL.so libGL.so libGLU.so
gb.v4l = libjpeg.so libpng.so Video4Linux >= 2.0
gb.xml = libxml-2.0
gb.xml.xslt = libxslt
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

nibbana
Foriker
Beiträge: 143
Registriert: Fr 16. Dez 2005, 21:32
Kontaktdaten:

Beitrag von nibbana » Mo 19. Jun 2006, 09:42

Bleibt aber immer noch die Frage in welchen Paketen die Sachen stecken. :? Und die richtigen Versionsnummer brauchst du auch noch.

mfg. nibbana
"Ich denke, also bin ich." (Descartes)

"Ich denke nicht, also was?" (Zen Meister Seung Sahn)

roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

Beitrag von roemi » Mo 19. Jun 2006, 11:32

Ich hämmer die Libs mal bei rpmseek rein.
Du kannst einem so schön die Ilusionen nehmen :wink:
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

Beitrag von roemi » Mo 19. Jun 2006, 12:08

Sodele, jetzt habe ich mal ein Pakete rausgesucht.
Wenn das ein oder andere nicht zu finden ist, dann muss man halt rpmseek.com erneut bemühen.

To compile Gambas, you must install the following libraries on your system :

Components = Libraries = Paket
gb.compress.bzlib2 = libbz2.so = bzip2
gb.compress.zlib = libz.so = zlib-devel
gb.corba = libACE.so libomniORB4.so libomniDynamic4.so = acroread, ? , ?
gb.crypt = libcrypt.so = glibc-devel
gb.db.firebird = libibpp.so libfbclient.so = ? , ?
gb.db.mysql = libmysqlclient.so libz.so = mysql-devel, zlib-devel (s.o.)
gb.db.odbc = libodbc.so = unixODBC
gb.db.postgresql = libpq.so = postgresql-devel
gb.db.sqlite2 = libsqlite.so = sqlite-devel
gb.db.sqlite = libsqlite3.so = sqlite-devel o. sqlite3-devel (s.o.)
gb.gtk = All GTK+ libraries
gb.ldap = libldap.so = openldap2
gb.net -
gb.net.curl = libcurl.so = curl.devel
gb.opengl = libGL.so libGLU.so = XFree86-Mesa-devel (beide)
gb.pcre = libpcre.so = pcre-devel
gb.qt = libqt-mt.so.3 = qt3
gb.qt.kde = All KDE libraries
gb.sdl = libSDL.so = SDL-devel
gb.sdl.sound = libSDL.so libSDL_mixer.so = SDL-devel, SDL_mixer
gb.sdl.image = libSDL.so libSDL_image.so libSDL_gfx.so libSDL_ttf.so = SDL-devel (s.o.), SDL_image-devel, ? , ? , SDL_ttf
gb.sdl.opengl = libSDL.so libGL.so libGLU.so = SDL-devel (s.o.), XFree86-Mesa-devel (s.o.), XFree86-Mesa-devel (s.o.)
gb.v4l = libjpeg.so libpng.so Video4Linux >= 2.0 = libjpeg-devel, libpng-devel, Video4Linux >= 2.0
gb.xml = libxml-2.0 = libxml-devel
gb.xml.xslt = libxslt = ?
Zuletzt geändert von roemi am Do 6. Jul 2006, 22:10, insgesamt 2-mal geändert.
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

Beitrag von roemi » Mo 19. Jun 2006, 21:20

THESE COMPONENTS ARE DISABLED:

- gb.compress.bzlib2
- gb.corba
- gb.db.firebird
- gb.db.odbc
- gb.net.curl
- gb.pdf


Nachdem ich 63 Pakete (165 MB) nachinstalliert habe, dieses Ergebnis :?

Ich werde nun nochmal im rpmseek nach Möglichkeiten suchen .

Nach nochmaligem durchgehen der Paketliste hab ich doch noch ein paar devels gefunden

THESE COMPONENTS ARE DISABLED:

- gb.corba
- gb.db.firebird
- gb.net.curl
- gb.pdf


Das soll mal reichen. Ich installiere jetzt mal und bereue es hoffentlich nicht
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

roemi
Site Admin
Beiträge: 389
Registriert: So 11. Dez 2005, 20:05
Wohnort: Hanau / Germany
Kontaktdaten:

Beitrag von roemi » Mi 21. Jun 2006, 07:19

HiHo,

also die genannte Liste ist nicht schlecht. Arcoread kann man sich sparen.
Ich habe keine Version gefunden die ich installieren konnte.

Wäre schön wenn man diese Liste weiter ergänzen würde.
Römi (seit 1989 bekennender Bergradfahrer und professioneller Biertrinker)
http://www.roemi.de

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast