Installation unter Ubuntu

Fragen und Informationen zur Installation von Gambas
Antworten
Tuxinator
Foriker
Beiträge: 4
Registriert: Do 20. Jul 2006, 14:04
Kontaktdaten:

Installation unter Ubuntu

Beitrag von Tuxinator » Do 20. Jul 2006, 14:10

Hi Leute,

ich bin neu hier im Forum.
Ich habe folgendes Problem: Ich wollte die neuste Version von Gambas mal installieren und ein wenig damit experimentieren. Da es aber weder für Ubuntu (ich benutze Dapper) noch für Debian die aktuelle Version gibt, hab ich gedacht ich kanns mir ja auch kompilieren. Naja, "./configure" geht auch ohne Probleme durch, aber bei "make" kommen irgendwann lauter Fehlermeldungen (irgendwas mit Syntax Error und so).
Deshalb meine Frage: Wie Kompiliere ich Gambas (1.9.34) unter Ubuntu bzw. gibt es aktuelle Repositorys für apt?

Ich hoffe ihr könnt mir helfen.
mfg Tuxinator

Tuxinator
Foriker
Beiträge: 4
Registriert: Do 20. Jul 2006, 14:04
Kontaktdaten:

Beitrag von Tuxinator » Fr 21. Jul 2006, 15:29

So ich hab jetzt ein paar Komponenten von Gambas deaktiviert, weil diese Fehler bereitet haben.
Das hat dann aber nur zum nächsten Fehler geführt... Ich hab das ganze folgendermaßen angegangen:
    ./configure -C --disable-pdf --disable-firebird --disable-corba --disable-odbc
    export CC=/usr/bin/gcc-2.95
    make
und dann kommt folgender Fehler:
    make[4]: Leaving directory `/home/tuxinator/gambas2-1.9.34/main/libltdl'
    Making all in gbx
    make[4]: Entering directory `/home/tuxinator/gambas2-1.9.34/main/gbx'
    source='gbx_c_class.c' object='gb_la-gbx_c_class.lo' libtool=yes \
    DEPDIR=.deps depmode=gcc /bin/sh ../depcomp \
    /bin/sh ../libtool --tag=CC --mode=compile /usr/bin/gcc-2.95 -DHAVE_CONFIG_H -I. -I. -I.. -I../share -I../libltdl -DGBX_INFO -pipe -Wall -fno-strict-aliasing -Wno-unused-value -g -Os -O0 -c -o gb_la-gbx_c_class.lo `test -f 'gbx_c_class.c' || echo './'`gbx_c_class.c
    /usr/bin/gcc-2.95 -DHAVE_CONFIG_H -I. -I. -I.. -I../share -I../libltdl -DGBX_INFO -pipe -Wall -fno-strict-aliasing -Wno-unused-value -g -Os -O0 -c gbx_c_class.c -Wp,-MD,.deps/gb_la-gbx_c_class.TPlo -fPIC -DPIC -o .libs/gb_la-gbx_c_class.occ1: Invalid option `-Wno-unused-value'
    make[4]: *** [gb_la-gbx_c_class.lo] Fehler 1
    make[4]: Leaving directory `/home/tuxinator/gambas2-1.9.34/main/gbx'
    make[3]: *** [all-recursive] Fehler 1
    make[3]: Leaving directory `/home/tuxinator/gambas2-1.9.34/main'
    make[2]: *** [all] Fehler 2
    make[2]: Leaving directory `/home/tuxinator/gambas2-1.9.34/main'
    make[1]: *** [all-recursive] Fehler 1
    make[1]: Leaving directory `/home/tuxinator/gambas2-1.9.34'
    make: *** [all] Fehler 2

Vielleicht kann ja damit jemand was anfangen.

nibbana
Foriker
Beiträge: 143
Registriert: Fr 16. Dez 2005, 21:32
Kontaktdaten:

Beitrag von nibbana » Fr 21. Jul 2006, 16:21

Ich denke du brachst eine neue Version von gcc. Deine stammt ja noch aus dem letzten Jahrtausend. :shock:

mfg. nibbana
"Ich denke, also bin ich." (Descartes)

"Ich denke nicht, also was?" (Zen Meister Seung Sahn)

Tuxinator
Foriker
Beiträge: 4
Registriert: Do 20. Jul 2006, 14:04
Kontaktdaten:

Beitrag von Tuxinator » Fr 21. Jul 2006, 20:09

Es hat jetzt funktioniert. Ich hatte extra den alten Compiler benutzt, weil in der Kompilieranleitung von Gambas steht das man es nur mit den gcc-Versionen 2.9x, 3.1 und 3.2 Kompilieren kann.
Bei mir hats jetzt doch mit gcc 4.0 funktioniert und ich freue mich schon darauf endlich loslegen zu können :D

mfg Tuxinator

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast