Gambas 2.5.x unter SuSE -Installationsprobleme

Fragen und Informationen zur Installation von Gambas
Antworten
anonymer1994
Foriker
Beiträge: 2
Registriert: So 4. Mai 2008, 23:19
Wohnort: Friesland, Paraguay
Kontaktdaten:

Gambas 2.5.x unter SuSE -Installationsprobleme

Beitrag von anonymer1994 » So 4. Mai 2008, 23:31

Hallo
Ich habe nun schon über 10 mal versucht, mir Gambas zu installieren, aber ich schaff es einfach nicht.
Ich habe zuerst versucht, mir aus den SuSE Repositories die ganzen einzelnen RPM Pakete runterzuladen und die dann einzeln zu installieren.
Das erste Paket (gambas2-2.5.0-5.1.i586.rpm) ließ sich ganz leich nd ohne Probleme installieren, bloß hat das überhaupt nichts gebracht, ich fand keine IDE, keinen Compiller, nichts...........
Also beschloss ich, die anderen Pakete einfach alle zu installieren, bis etwas funktioniert.
Bei 2. Paket gab es (gambas2-devel-2.5.0-5.1.i586.rpm) gab es dann unerfüllte abhängigkeiten. Ich sollte des runtime installieren.
Nur hat das irgendeinen unverständlichen error gemacht.
Ich habe verschiede RPMs zerlegt und Manuel installiert, es bringt alles nichts.
Dann öffnete ich YaST, gab gambas und dann gambas2 ein, ließ suchen und alles was er fand war ein Paket namen..........
gambas2! Es war als bereits installiert markiert.
Ich frage mich, warum es nur 1 Paket anzeigt, wenn in den Repositories mehrere sind.
Als das alles nichts brachte habe ich mir einfach mal die Sourcen gezogen
und als ich configure ausführte sagte er mit, das einige libs wie z.b. die
libintl.so fehlt.........
YaST---->Suche---->kein ergebniss
Ich frage mich was mit meiner Kiste los ist, es muss doch irgendeine möglichkeit geben, eine IDE zu installieren.........
Bin allen antworten dankbar.

Anonymer

Benutzeravatar
OderMalSo
Foriker
Beiträge: 65
Registriert: Mi 18. Apr 2007, 22:30
Wohnort: Mönchengladbach
Kontaktdaten:

Beitrag von OderMalSo » Mo 5. Mai 2008, 17:12

Die libintl.so befindet sich im Paket gettext-devel.

Was fehlt noch?
Grüßle
Georg
openSuSE 11.1 - Gambas2 2.11.1 & Gambas3 SVN
Bild

anonymer1994
Foriker
Beiträge: 2
Registriert: So 4. Mai 2008, 23:19
Wohnort: Friesland, Paraguay
Kontaktdaten:

Beitrag von anonymer1994 » Mo 5. Mai 2008, 19:08

Nun, ich habe mir das Paket runtergeladen, abe rdas Paket benötigt
folgendes:
error: Failed dependencies:

gettext = 0.15 is needed by gettext-devel-0.15-22.i586
libgettextlib-0.15.so is needed by gettext-devel-0.15-22.i586
libgettextsrc-0.15.so is needed by gettext-devel-0.15-22.i586

Also such ich auch das und will es installieren aber dann:

katze-linux:/home/felix/Downloads/RPMs/Gambas/Require # rpm -i gettext-0.15-22.i586.rpm
package gettext-0.16-47 (which is newer than gettext-0.15-22) is already installed
file /usr/bin/envsubst from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/bin/gettext from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/bin/gettext.sh from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/bin/msgfmt from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/bin/ngettext from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/lib/libasprintf.so.0.0.0 from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/gettext/ABOUT-NLS from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man1/envsubst.1.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man1/gettext.1.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man1/msgfmt.1.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man1/ngettext.1.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man3/bind_textdomain_codeset.3.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man3/bindtextdomain.3.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man3/gettext.3.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man3/ngettext.3.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47
file /usr/share/man/man3/textdomain.3.gz from install of gettext-0.15-22 conflicts with file from package gettext-0.16-47

Es wird als installiert angezeigt, wärend das andere Paket dies als nicht erfüllte abgängikeit erkennt.
Wie hast du dir das ding denn installiert?


Anonymer

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast