Gambas3x trunk Version

Alle sonstigen Themen wie Fragen zur IDE, Fehler, Paketierung, ...
Antworten
Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Gambas3x trunk Version

Beitrag von Naubaddi » Mi 6. Mai 2015, 08:31

Hi,

mir ist aufgefallen das meine Uhr (Gambas-Programm) nur noch 1 - 2% CPU-Last verursacht statt 7 - 9%, hat sich also was getan bei Gambas was man nicht sofort sehen kann :-).

Grüßle
Gruß, Naubaddi

tux_
Moderator
Beiträge: 946
Registriert: Di 11. Nov 2008, 20:05
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von tux_ » So 10. Mai 2015, 15:17

Wie erfrischend, auch mal etwas positives ueber Gambas zu lesen. Ich bekomme es sonst nur mit Beschwerden zu tun. Schoen! :-)
Achtung: Es passiert, dass ich einen frisch geschrieben Beitrag innerhalb von 10 Minuten noch 3-4 Mal aendere!

Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von Naubaddi » Mo 25. Mai 2015, 10:58

Hi,

nach dem Update auf "gambas3 3.7.90+svn70 all" startet Gambas mit der Fehlermeldung:

Code: Alles auswählen

This application has raised an unexpected
error and must abort.

[63] 'Form.Activate' is incorrectly overridden in class 'FWorkspace'.
Workspace._new.34


und wird nicht gestartet.

Ist der Fehler schon bekannt?

Grüßle
Gruß, Naubaddi

tux_
Moderator
Beiträge: 946
Registriert: Di 11. Nov 2008, 20:05
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von tux_ » Mo 25. Mai 2015, 11:33

Nein, aber gutes Auge! Der Fehler sollte eigentlich bald bekannt werden :-) Minisini hat gestern nachmittag der Window-Klasse eine neue Activate-Methode gegeben. Form erbt von Window und Workspace arbeitet mit einer internen Klasse, die von Form erbt, aber bereits eine eigene (signatur-inkompatible) Activate-Methode hat. Daher der Fehler. Scheinbar hat niemand bisher die IDE gestartet?

EDIT: Ich habe gerade das neuste Gambas installiert und bei mir funktioniert alles ad-hoc... Ich werde trotzdem einmal nachfragen.
Achtung: Es passiert, dass ich einen frisch geschrieben Beitrag innerhalb von 10 Minuten noch 3-4 Mal aendere!

Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von Naubaddi » Mo 25. Mai 2015, 14:07

Hi,

tux_ hat geschrieben:...Ich habe gerade das neuste Gambas installiert und bei mir funktioniert alles ad-hoc... Ich werde trotzdem einmal nachfragen.


Danke, würde es ja selber melden wenn da nicht das Englische wäre.

Gibt es eine Möglichkeit auf eine vorher funktionierende Version zu wechseln?

Grüßle
Gruß, Naubaddi

tux_
Moderator
Beiträge: 946
Registriert: Di 11. Nov 2008, 20:05
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von tux_ » Di 26. Mai 2015, 09:33

Ich habe gerade noch einmal im Quelltext nachgesehen. Die Methode, die den Namenskonflikt verursacht haben soll, wurde in Revision 7097 (Sonntag nachmittag) umbenannt -- im gleichen Commit, in dem der Namenskonflikt ueberhaupt erst zustande gekommen waere. Vielleicht hast du ein kaputtes Paket erwischt? Kannst du versuchen, Gambas zu reinstallieren?
Achtung: Es passiert, dass ich einen frisch geschrieben Beitrag innerhalb von 10 Minuten noch 3-4 Mal aendere!

Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von Naubaddi » Di 26. Mai 2015, 10:42

Hi tux_,

habe den Ordner "~/.config/gambas3" gelöscht und mit:

Code: Alles auswählen

sudo apt-get autoremove gambas3
sudo add-apt-repository --remove ppa:gambas-team/gambas-daily
sudo apt-get update

Gambas entfernt.

Anschließend mit:

Code: Alles auswählen

sudo add-apt-repository ppa:gambas-team/gambas-daily
sudo apt-get update
sudo apt-get install gambas3

gambas neu installiert. Laut "dpkg -l gambas3" ist nun "gambas3 3.7.90+svn70 all" auf meinem Rechner. Es kommt immer noch die gleiche Fehlermeldung und Gambas startet nicht.

Grüßle
Gruß, Naubaddi

tux_
Moderator
Beiträge: 946
Registriert: Di 11. Nov 2008, 20:05
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von tux_ » Di 26. Mai 2015, 11:14

Laut [0] sollte die neuste Version des Daily-Builds-PPA den Namen "3.7.90+svn7098+..." tragen. Die "svn70" bei dir irritiert mich etwas. Ich kenne mich aber mit Ubuntu und PPAs eigentlich gar nicht aus. Vielleicht ist hier jemand, der helfen kann und ueberhaupt ein Ubuntu zur Hand hat?

[0] https://launchpad.net/~gambas-team/+archive/ubuntu/gambas-daily
Achtung: Es passiert, dass ich einen frisch geschrieben Beitrag innerhalb von 10 Minuten noch 3-4 Mal aendere!

Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von Naubaddi » Di 26. Mai 2015, 12:25

Hi tux_,

dann warte ich ein paar Tage bis es eine neue Version gibt die wieder funktioniert, habe auf dem kleinen ASUS Transformer für den Notfall noch eine funktionierendes Gambas.

Gibt es noch eine andere relativ einfache Möglichkeit gezielt eine Gambas-Version zu installieren?

Grüßle
Gruß, Naubaddi

tux_
Moderator
Beiträge: 946
Registriert: Di 11. Nov 2008, 20:05
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von tux_ » Di 26. Mai 2015, 12:47

dann warte ich ein paar Tage bis es eine neue Version gibt die wieder funktioniert

Du kannst auch statt der Daily-Builds die stabile Gambas-Version 3.7.1 aus einem PPA beziehen. Wenn du nicht unbedingt die allerneusten Features (und Bugs) von gestern nacht haben musst, ist das zu empfehlen. Siehe dazu das Wiki[0]. Bevor du das "gambas3"-PPA hinzufuegst, muss das "gambas-daily"-PPA entfernt werden.

Gibt es noch eine andere relativ einfache Möglichkeit gezielt eine Gambas-Version zu installieren?

Soweit *ich* weisz, nicht. Die PPAs halten nur das jeweils aktuellste Paket fuer eine Ubuntu-Version. Und nach den PPAs bleibt eigentlich nur selbst kompilieren, was fuer den Unerfahrenen nicht mehr "relativ einfach" ist. Eventuell hast du noch eine alte Gambas-Version in deinem Paket-Cache. Gegebenenfalls kannst du dieses Paket zum Downgraden von Gambas benutzen. Das funktioniert aber nur fuer Gambas-Versionen, die du selbst installiert hattest und die noch in deinem Paket-Cache liegen.

[0] http://gambaswiki.org/wiki/install/ubuntu
Achtung: Es passiert, dass ich einen frisch geschrieben Beitrag innerhalb von 10 Minuten noch 3-4 Mal aendere!

Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Re: Gambas3x trunk Version

Beitrag von Naubaddi » Di 26. Mai 2015, 13:28

Hi,

alles nicht so einfach :wink: , irgendwie bekomme ich die neueste Version nicht "dpkg -s gambas3" ergibt:

Code: Alles auswählen

Version: 3.7.90+svn7091+build27~ubuntu14.04.1


Werde einfach

* auf dem Kleinen mit der funktionierenden trunk-Version programmieren
* auf dem Großen die trunk-Version kontinuierlich updaten und warten bis es wieder funktioniert.

Grüßle
Gruß, Naubaddi

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast