Error: Dependency is not satisfiable: gambas3-runtime

Probleme, Fragen und Lösungen
Antworten
Benutzeravatar
xenix
Foriker
Beiträge: 24
Registriert: Fr 22. Jun 2012, 21:01
Kontaktdaten:

Error: Dependency is not satisfiable: gambas3-runtime

Beitrag von xenix » Fr 22. Jun 2012, 21:23

Hallo liebe Gambas Gemeinde,

ich habe folgendes Problem wenn ich mein Gambasprogramm auf ein anderen Rechner installiere.
Es kommt die Meldung:
Error: Dependency is not satisfiable: gambas3-runtime (>= 3.0.9)

Auf mein Rechner läuft Mint 13 mit Gambas3.1.1 und auf den Zielrechner Ubuntu 10.04 ohne Gambas.
Ich habe Ubuntu als Zielpaket in Gambas ausgewählt.

Ist das ein Bug? Sollte ich lieber mit Gambas2 entwickeln oder hab ich dort auch diese Probleme?
Dateianhänge
error.jpg
error.jpg (68.26 KiB) 3481 mal betrachtet
Grüße!


-Unix's verlorener Sohn-

tux_
Moderator
Beiträge: 941
Registriert: Di 11. Nov 2008, 20:05
Kontaktdaten:

Re: Error: Dependency is not satisfiable: gambas3-runtime

Beitrag von tux_ » Mo 25. Jun 2012, 06:55

Hi,

Gambas ist, wie du sicher weiszt, eine interpretierte Sprache und als solche benoetigt sie einen Interpreter, Runtime, VM oder wie man es auch immer nennen mag. Wenn du nicht diese gambas3-runtime (Interpreter) und jede der von deinem Projekt benoetigten Komponenten installiert hast, wird das Programm nicht laufen. Die IDE, mit der du das Installationspaket geschnuert hast, traegt diese o.g. Abhaengigkeiten automatisch ein. Daher: auf dem Zielsystem muss ebenfalls Gambas laufen, dann hast du i.d.R. schon eine Obermenge des Benoetigten installiert.

Jetzt kommt aber der Clou. Ubuntu besitzt _noch_ keine offiziellen Gambas3-Pakete in seinen Repositorien, du muesstest also zu einem PPA[1] greifen.

MfG,
tux_

[1] https://launchpad.net/~nemh/+archive/gambas3
Achtung: Es passiert, dass ich einen frisch geschrieben Beitrag innerhalb von 10 Minuten noch 3-4 Mal aendere!

Benutzeravatar
xenix
Foriker
Beiträge: 24
Registriert: Fr 22. Jun 2012, 21:01
Kontaktdaten:

Re: Error: Dependency is not satisfiable: gambas3-runtime

Beitrag von xenix » Mo 25. Jun 2012, 11:05

Danke für den Tip!

Hier mal für alle die das gleiche Problem haben. Terminal öffnen und folgendes reinschreiben:

# sudo add-apt-repository ppa:nemh/gambas3
# sudo apt-get update

sollte laut Beschreibung ab Ubuntu 9.10 oder höher gehen.
Grüße!


-Unix's verlorener Sohn-

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast