Gambs unter neueren Linux? Geht bei mir nicht.

Fragen und Informationen zur Installation von Gambas
Antworten
gambasso
Foriker
Beiträge: 808
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Gambs unter neueren Linux? Geht bei mir nicht.

Beitrag von gambasso » Fr 5. Feb 2016, 13:54

moin,

ich habe versucht Gambas auf neuen Linux-Versionen zu installieren. Zuerst wie vorgeschlagen über 'sudo apt-get....'. War nichts. Konnte meine Programme nicht ausführen. Meckerte, einige Elemente im Programm konnte gambas nicht zuordnen.
Habe es deinstalliert und über die 'Synaptic-Paketverwaltung' Gambas für V15.10 installiert.
Gleiches Ergebnis. In den Komponenten-Einstellungen habe ich kein 'qt4' sondern nur 'qt5' gefunden. Ist das der Grund für die Fehlermeldungen?

Wie bekomme ich meine Programme nun unter neueren Linux-Versionen zum laufen?
Gruss

gambasso
Foriker
Beiträge: 808
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: Gambs unter neueren Linux? Geht bei mir nicht.

Beitrag von gambasso » Fr 5. Feb 2016, 20:08

ich habe es mit viel Mühe hinbekommen. Mit einer 5 Moante alten Backup des Systems von Xubuntu V16.04. Aber ich muß zum Updaten V15.10 angeben.
Direkt für V15.10 installieren war nichts. Kein 'qt4' und kaum ein Programm lief deswegen. Updaten sowohl von Xubuntu und Gambas3 klappte aber.

Gibt es keine Konvertierungsmöglichkeit? Da werden die nicht verstandenen 'Formen' einfach weggeschaltet und man diese dann kaum ändern.
Beim Laden des Programms erschien besagte Form erst gar nicht, auch nicht in den Reitern der IDE.
Das ist blöd gelöst. Ich mußte das zuständige File (.src/Formxy.form) mittels eine externen Editors ändern, um überhaupt wieder daran zu kommen.
Anschließend natürlich alle Einträge bezüglich des Elements mit einem Hochkomma versehen.
Gruss

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste