neue Version 3.16 nicht alles ok

Alle Fragen zur Programmierung, die nicht in die speziellen Themen passen
Antworten
gambasso
Foriker
Beiträge: 1140
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

neue Version 3.16 nicht alles ok

Beitrag von gambasso » So 18. Apr 2021, 14:00

moin,

in der neuen Version 3.16 erscheint nach laden eienes geschriebenen Programms ein Fenster :
bei_start_2021-04-18_14-30-05.png
bei_start_2021-04-18_14-30-05.png (15.61 KiB) 114 mal betrachtet
Nach einem erneuten Laden klappt es meistens.

Hat es geklappt, erscheinen die einzelnen Module, Classen, Formen oft nicht als Reiter in der Menüleiste.
Kann man das ändern?
Gruss

Benutzeravatar
tionov
Site Admin
Beiträge: 381
Registriert: So 18. Mai 2014, 22:40
Kontaktdaten:

Re: neue Version 3.16 nicht alles ok

Beitrag von tionov » So 18. Apr 2021, 17:40

Wenn du ein Projekt zu Verfügung stellen kannst, mit dem sich das Problem reproduzieren lässt, zusammen mit den Systeminformationen können wir es dem Gambas Bugtracker übergeben und dann wird sich Benoît darum kümmern.
Alles Gute,

tionov

gambasso
Foriker
Beiträge: 1140
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: neue Version 3.16 nicht alles ok

Beitrag von gambasso » So 18. Apr 2021, 18:15

Das Dumme ist, vor dem 1.Aufruf weiss ich nicht, ob es klappt oder nicht.
Nach dem 2.Aufruf klappt es meistens, bisher jedenfalls.
Da müßte ich erst mal einige viele versuchen, vielleicht finde ich ein Prg.
Gruss

gambasso
Foriker
Beiträge: 1140
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: neue Version 3.16 nicht alles ok

Beitrag von gambasso » Mo 19. Apr 2021, 11:26

Noch was bemerkt habe ich:

im 'Form.TextEditor' sind die 'Highlight' Aufrufe und Darstellung anders als vorher.

Vorher konnte ich nach Darstellung eines Textes diesen durch Auswahl eines Highlight-Parameters ändern.
Das funktionierte zuesrst gar nicht. Habe dann zu Beginn des Programms die Zeile 'TextEditorXY.Highlight = "diff" ' eingefügt.
Dann konnte ich was ändern.

Der Text verträgt bei einem 'Highlight' kein Hochkomma " ' " und kein " @ ". Die Farbe danach bleibt wie dieses Zeichen.

Mal sehen was noch kommt.
Gruss

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste