ich erhalte Fehlermeldung >

Alle Fragen zur Programmierung, die nicht in die speziellen Themen passen
Antworten
gambasso
Foriker
Beiträge: 920
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

ich erhalte Fehlermeldung >

Beitrag von gambasso » Do 7. Dez 2017, 18:49

moin,

Gambas 3.9 mit QT5 / will nicht anders!
ich möchte Hilfeseiten im 'WebView' darstellen. Unter den älteren Linux-Versionen klappt es, bei den neueren Versionen nicht.

Der Befehl: 'WebView3.Url = "/home/USER/gambas/Grundlagen/verzeichnis/help/dm_hlp_001.html" wird total ingnoriert.
Statt dessen wird der 'Applications.Path' eingetragen. ???
' gambas code
WebView3.Url = ""
' löscht den Pfad, aber ich kann keinen anderen Pfad übergeben, es kommt immer nur der 'Applications.Path'!

Auch eine Fehlermeldung kommt:
** (gbx3:2029): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-A590yMA7av: Verbindungsaufbau abgelehnt
Was soll das bedeuten und wie krieg ich das hin.
Gruss

Benutzeravatar
gambi
Moderator
Beiträge: 319
Registriert: Mi 8. Mai 2013, 21:46
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von gambi » Do 7. Dez 2017, 21:29

Hallo gambasso,

mit gambas 3.10 und WebView3.Url = User.Home &/ "Dokumente/dm_hlp_001.html"
bekomme ich eine Seite angezeigt.

Die aktivierten Komponenten:
gb
gb.form
gb.gui.qt (QT4/QT5 Wechselkomponente)
gb.gui.qt.webkit (QT4/QT5 Webkit Wechselkomponente)
gb.image

gg

gambasso
Foriker
Beiträge: 920
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von gambasso » Fr 8. Dez 2017, 10:17

moin,

ich muß es mit 'WebView3.Html" = Varaiable machen, ansonsten kommt gar nichts. Aber die Formatierung ist futsch.

Als BS benutze ich Xubuntu 17.10 und/oder 18.04 zum Testen. Unter 18.04 läuft bisher nur Gambas 3.9 und QT5.
Gruss

Benutzeravatar
gambi
Moderator
Beiträge: 319
Registriert: Mi 8. Mai 2013, 21:46
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von gambi » Fr 8. Dez 2017, 10:41

Hallo gambaasso,
stelle doch bitte dein Projekt, bzw. erstelle ein Teilprojekt, aus dem der Fehler hervorgeht, zur Verfügung.

Ich kann das nicht nachvollziehen (s. posting.php?mode=reply&f=3&t=5502#pr12680)!

gg

besenmuckel
Foriker
Beiträge: 81
Registriert: Di 4. Nov 2014, 21:11
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von besenmuckel » Fr 8. Dez 2017, 16:14

Sollte auch so gehen mit Datei(file://).

Code: Alles auswählen

WebView3.Url = "file:///home/USER/gambas/Grundlagen/verzeichnis/help/dm_hlp_001.html"

gambasso
Foriker
Beiträge: 920
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von gambasso » Fr 8. Dez 2017, 16:38

moin,

@ besenmuckel: schon alles was so bekannt ist versucht.
Ich kann von V17.10 kein Archiv erstellen, dabei stürzt Gambas sofort ab.
Ich habe daraufhin ein Systemaktualisierung per Terminal durch geführt, dabei kam folgende Fehlermeldung:
Vorbereitung zum Entpacken von .../gambas3-dev_3.10.0+git5950.9786d95+build1.4250560.1.fb554bc~ubuntu17.10.1_amd64.deb ...
Entpacken von gambas3-dev (3.10.0+git5950.9786d95+build1.4250560.1.fb554bc~ubuntu17.10.1) über (3.9.2-2build4) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/gambas3-dev_3.10.0+git5950.9786d95+build1.4250560.1.fb554bc~ubuntu17.10.1_amd64.deb (--unpack):
Versuch, »/usr/share/man/man1/gbh3.1.gz« zu überschreiben, welches auch in Paket gambas3-runtime 3.9.2-2build4 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/gambas3-dev_3.10.0+git5950.9786d95+build1.4250560.1.fb554bc~ubuntu17.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Was heist das schon wieder? Wie bekomme ich das behoben?
Gruss

gambasso
Foriker
Beiträge: 920
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von gambasso » Fr 8. Dez 2017, 17:24

Habe unter V17.10 Gambas deinstalliert und per Terminal wieder neu installiert.
Es wurde Gambas3.10 installiert mit 'QT4'.
Jetzt klappt auch die Darstellung im 'WebView'.
Da muß ich wohl eine Aktualisierung unterbinden, nur wie lange?

Jetzt werde ich es mal unter V18.04 angehen.
Gruss

besenmuckel
Foriker
Beiträge: 81
Registriert: Di 4. Nov 2014, 21:11
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von besenmuckel » Fr 8. Dez 2017, 17:37

Gambas3 Version 3.10 steht im Konflikt mit eine installierte Gambas3 Version 3.9.2
Ich verwende Debian-Stretch mit Gambas3 Version 3.9.1-3
Gambas 3 Version 3.10 bisher nur live mit Mint 18.x getestet.
Überprüfen welche Version bei dir installiert ist und verfügbar ist kannste mit Befehl

Code: Alles auswählen

apt-cache policy gambas3
Ich vermute mal du hast die Gambas3 Version 3.9.2 über den Paketmanager installiert und Gambas3 Version 3.10 über PPA installiert.
Heruntergeladene Pakete werden im Verzeichnis /var/cache/apt/archives/ gespeichert. Das Verzeichnis leeren kann man mit Befehl

Code: Alles auswählen

sudo apt-get clean
Dies löst aber nicht dein Problem. Du must die alte Gambas3 Version 3.9.2 löschen, wenn du Gambas3 Version 3.10 verwenden möchtest. Evtl muss du Gambas3 komplett löschen und neu installieren.
Möchtest du Gambas3 Version 3.9.2 verwenden mustte Gambas3 Version 3.10 aus den source herrausnehmen, dann Liste neu einlesen.

Code: Alles auswählen

sudo apt-get update
Gambas3 komplett mit Einstellungen(purge) löschen mit Befehl nicht getestet.

Code: Alles auswählen

sudo apt-get remove --purge gambas3*
Ob alle Einstellungen mit weg sind. kann ich dir nicht sagen. Es ist evtl noch dieser Befehl notwendig

Code: Alles auswählen

sudo apt-get autoremove --purge
Damit werden auch die nicht mehr benötigten Pakete entfernt.
Zum löschen kann man auch statt der Konsole andere Programme nehmen, wie z. B. synaptic hier dann Rechtsklick Paket vollständig entfernen.
Besser kann ich das nicht erklären
Zuletzt geändert von besenmuckel am So 10. Dez 2017, 01:39, insgesamt 1-mal geändert.

besenmuckel
Foriker
Beiträge: 81
Registriert: Di 4. Nov 2014, 21:11
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von besenmuckel » Fr 8. Dez 2017, 18:07

Dann ist ja gut war zu langsam mit den schreiben.
Jetzt werde ich es mal unter V18.04 angehen.
Wenn du dies testest, kannste ja überprüfen welche Version dir dein Paketmanager installieren will

Code: Alles auswählen

sudo apt-get update
apt-cache policy gambas3
Bevor du diese Version installierst dann gleich z. B. Gambas3 Version 3.10 über PPA installieren

gambasso
Foriker
Beiträge: 920
Registriert: Sa 17. Mär 2012, 09:55
Kontaktdaten:

Re: ich erhalte Fehlermeldung >

Beitrag von gambasso » Fr 8. Dez 2017, 18:54

Unter V18.04 hat sich Gambas3.9.2 mit QT5 installiert. (sudo apt-get install gambas3)

Damit klappt aber auch der WebView nicht. V18.04 hat einen neueren Kernel, ob es daran liegt?

Warum sonst mal so und dann wieder so?

Jede Installation ist anders. Ich habe ein Tower mit mehreren Wechselrahmen und dementsprechenden Festpaltten. Ich habe noch nie erlebt, daß eine Linux-Installation, trotz gleicher Version, identisch mit einer anderen gleichen Version war. (gleiche Version auf mehreren Platten)
Es ist aber zum Testen ganz nett.
Gruss

Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 7 Gäste