Ersatzwert bei Settings n.i.O.

Alle sonstigen Themen wie Fragen zur IDE, Fehler, Paketierung, ...
Antworten
Naubaddi
Foriker
Beiträge: 90
Registriert: Di 10. Jan 2012, 21:30
Kontaktdaten:

Ersatzwert bei Settings n.i.O.

Beitrag von Naubaddi » Mo 26. Jan 2015, 20:35

Hi,

kann es sein das im Gambas Buch " http://www.gambas-buch.de/dw/doku.php?i ... .1.1:start " ein kleiner Fehler steckt?

Dieses steht im Gambas Buch:

Auf die Konfigurationsdaten in der Konfigurationsdatei wird zur Programmlaufzeit über die Kombination Sektionsname/Schlüssel oder beim Programmstart bei nicht vorhandenem Schlüssel-Wert-Paar auf den Vorgabewert zugegriffen, wie der folgende Ausschnitt aus dem Quelltext für das Projekt Temperaturmessung im Ereignis Form_Open() zeigt:

Code: Alles auswählen

Syntax:    Wert = Setting-Objektname["Sektionsbezeichner/Schlüsselname", optional "Vorgabewert"]

expRX_TX.Hidden = v24Settings["Expander/ExpanderHiddenStatus", "TRUE"]       --->    False
cmbSpeed.Text   = v24Settings["V24Konfiguration/Geschwindigkeit", "4800"]   --->    9600
cmbParity.Text  = v24Settings["V24Konfiguration/Parität", "NONE"]      --->   NONE


Bei Zahlen ist es egal ob diese in Anführungszeichen stehen, nicht bei True und False. Wenn noch kein Wert für True/False existiert und der Ersatzwert genommen wird ergibt "True" und "False" True, ohne Anführungszeichen beim Ersatzwert funktioniert es.

Grüßle
Gruß, Naubaddi

Honsek
Foriker
Beiträge: 328
Registriert: Do 4. Okt 2007, 17:01
Kontaktdaten:

Re: Ersatzwert bei Settings n.i.O.

Beitrag von Honsek » Di 3. Mär 2015, 19:31

Hallo Naubaddi,

der angemahnte Fehler ist auf allen betroffenen Seiten korrigiert worden.
Dank für den Tipp.

Mit freundlichem Gruß

Hans
---> Wenn Du eine gute Antwort erwartest, musst Du sehr gut fragen!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste